Subaru B9 Trifecta SUV Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter · #1 ·
Along with the close-to-unbearable delay in transmission I've noticed in my (and other) Tribecas, the weak remote is my other major complaint.

Has anybody else noticed how trying to unlock can be oh-so frustrating? (especially when you're trying to unlock all doors and the goal is to squeeze in two chirps within 2-3 seconds). :mad:

It seems it's worse when you're on the driver side, from behind... Tough luck since it's where most of us come from when getting in the car (I assume that little plastic half-sphere on the right hand side of the dash-board is what to aim for...). I've had multiple cars over the last few years and this is, by far, the worse I've seen.

Does anybody know of an easy solution? Maybe some kind of antenna booster that can be fitted within the remote?
 

·
Registered
Joined
·
26 Posts
Must be an '08 thing, because

my 07 B9 has none of those problems. In fact, I am amazed at the range of the remote, & the fact that it can operate thru glass, my garage door & from my pocket - without being aimed - from a distance of about 50 yards.

On the other hand, it may be that the battery is weak in the transmitter. Have you tried the other set of keys to see if both are acting the same?
 

·
Registered
Joined
·
1,246 Posts
I don't have any issues with our remote. It works great even out of line of sight. I would change the batteries. If that doesn't work, hold the remote to your head. It will act as an antenna. No joke, it really works. It will extend the range of your remote.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #4 ·
I'll try the other set of keys - why on earth didn't think of that first... :eek: )
I see both of you guys own '07... It could also be the remote models are different from the '08.

I saw the "user your head" trick... That was funny! Beside being worried people might think I'm crazy, I'm not sure I want to do that every time.
My last option would be a video I found online of a guy that solders a simple piece of electrical cable to the antenna inside the remote (http://www.metacafe.com/watch/358044/boost_your_car_remote_range/)
 

·
Registered
Joined
·
552 Posts
tbertran said:
I assume that little plastic half-sphere on the right hand side of the dash-board is what to aim for...).
That little sphere is actually a sun light sensor, not an antenna. It's for the automatic climate control...it'll boost the A/C & fan speed if it senses the hot sun beaming into the windshield.
 

·
Registered
Joined
·
192 Posts
I just wish there was a way to have an "unlock all" feature without having to hit the button a million times. There's nothing like carrying a kid in one arm and trying to unlock their door with the other hand while in the rain! :mad:
 

·
Registered
Joined
·
80 Posts
tbertran said:
I'll try the other set of keys - why on earth didn't think of that first... :eek: )
I see both of you guys own '07... It could also be the remote models are different from the '08.
http://www.metacafe.com/watch/358044/boost_your_car_remote_range/)
I've noticed problems on my 08 remote as well, but more on trying to lock the vehicle. After I get out of the car and hit the lock button it doesn't respond. Stepping closer to the car also doesn't work. Today I had to actually lock the doors manually via the lock button on the door handle. I'm not sure if its the battery but i've been able to unlock and lock from my window 6 stories up. It happens every now and then so I think i'll start carrying both remotes to see if its indeed a battery issue. I'll also be stopping by the dealership to check out oil levels today so maybe I'll ask them. Keep you posted.
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #9 ·
That's precisely what my problem is. It'll work from 100 yards but, at times, it won't work when I'm standing 3 feet away in a particular spot (often when I'm behind it on the side).
In any case, I have noticed that compared to my other cars, I need to press the remote button a good second longer every time for it to work.

SubieTri08 said:
I've noticed problems on my 08 remote as well, but more on trying to lock the vehicle. After I get out of the car and hit the lock button it doesn't respond. Stepping closer to the car also doesn't work. Today I had to actually lock the doors manually via the lock button on the door handle. I'm not sure if its the battery but i've been able to unlock and lock from my window 6 stories up. It happens every now and then so I think i'll start carrying both remotes to see if its indeed a battery issue. I'll also be stopping by the dealership to check out oil levels today so maybe I'll ask them. Keep you posted.
 

·
Registered
Joined
·
80 Posts
Ok so I stopped by my dealers service dept today. Told them about the remote issue and they said to give them a call back a few days before I go back to them the next time and they'll order another key. I would need to bring my secondary and valet key back to get them all reprogrammed. He said sometimes the chip goes bad or doesn't click too well. My guess is that they've seen this happen enough for him to tell that it needs to be replaced. So you might want to check back with your dealer to have the keys redone. Hope this helps, let me know what happens. I'll be returning to them next month to get the keys done when I have time.
 

·
Registered
Joined
·
96 Posts
tbertran said:
Along with the close-to-unbearable delay in transmission I've noticed in my (and other) Tribecas, the weak remote is my other major complaint.

Has anybody else noticed how trying to unlock can be oh-so frustrating? (especially when you're trying to unlock all doors and the goal is to squeeze in two chirps within 2-3 seconds). :mad:

It seems it's worse when you're on the driver side, from behind... Tough luck since it's where most of us come from when getting in the car (I assume that little plastic half-sphere on the right hand side of the dash-board is what to aim for...). I've had multiple cars over the last few years and this is, by far, the worse I've seen.

Does anybody know of an easy solution? Maybe some kind of antenna booster that can be fitted within the remote?
Have good luck pointing the key part at the car. Seems very particular where you aim it.

MNSteve
 

·
Registered
Joined
·
11 Posts
Discussion Starter · #12 ·
Well I've been using my second key for a few days and I've seen a major improvement. I'll be following a previous poster's advice and ask the dealership to order me new keys...
 

·
Registered
Joined
·
134 Posts
I know we probably have a different system over here but our '07 is awful too. The dealer has suggested that we bring both keys in to re-tune them.
There seems to be a line of sight issue - you sometimes need to walk right up to the driver's door and point the key inside.
My '00 Impreza has a system that is prone to interference from some radio transmissions. I have been stranded a couple of times when parking near a Police Station.
I assume that our cars are imported without alarm systems and the UK fit options chosen by Subaru UK seem to be a constant weak point.
 

·
Registered
Joined
·
151 Posts
I have the same problem trying to open all the doors. There is a certain timing you have to hit correctly to get it to work... double click too fast and it doesnt open all the doors. I just end up hitting it 5-6 times and it eventually opens.
I don't know why they just don't open all the doors with one push. My Code remote on my OB is so simple.. 2 buttons, one opens all one shuts all.
 
1 - 14 of 14 Posts
Top