Subaru B9 Trifecta SUV Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hey Guys, I’m having some problems with my 2007 3.0 tribeca.
my computer threw the P0011, P0021, and P0018 codes at me.
I changed the timing chain and all tensioners, all the timing marks were perfect. I assembled everything and it ran fine for a while, then The codes popped up. Any ideas on where to start?
Looks like the previous owner had the VVT solenoid changed in the drivers side.
 

·
Administrator
Joined
·
627 Posts
Hey Guys, I’m having some problems with my 2007 3.0 tribeca.
my computer threw the P0011, P0021, and P0018 codes at me.
I changed the timing chain and all tensioners, all the timing marks were perfect. I assembled everything and it ran fine for a while, then The codes popped up. Any ideas on where to start?
Looks like the previous owner had the VVT solenoid changed in the drivers side.
No experience here. I hate to say it but did you check the Outback forums?
 

·
Registered
Joined
·
32 Posts
1) I would say that it is a bit rude - throwing codes at people who need to find their explanation by themselves...
2) subaru does not have vvt, but avcs. in your case - also avls.
3) my guess - either solenoids have gone bad and/or infamous metallic filters in screws have clotted.
3.1) for solenoids - I would log camshaft position related parameters(not sure about oil pressures available for logging, but that would be worth checking too).
tactrix or vag cable + romraider/ecuexplorer/freessm ... something along these lines... or if you have deep pockets - subaru dealerships with ssm :D
3.2) filters - just throw them out (as did Subaru, some time after starting producing the engine).
 
1 - 3 of 3 Posts
Top