Subaru B9 Trifecta SUV Forum banner
1 - 5 of 5 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter · #1 ·
Wife calls me last night to tell me that the CEL, Traction Control Light were on and that the Cruise Control light just started flashing.

When she came home, the first thing i did was check the gas cap...It was a little loose. I figured that was the problem...

I have a ScanGauge II and the code came up as P0463 (Fuel Level Sensor Circuit High Input). Figuring that it must be related to the loose cap, I cleared the code and all seemed well.

However, she just called to tell me that the lights are all back on....

My question is, what is this code? Loose/bad ground to fuel pump/sender?

Will it hurt to wait until next Thursday? (the only day i could get a loaner)

Thanks - John

EDIT - this is an 08 Tribeca...
 

·
Registered
Joined
·
552 Posts
Was that the only code? Several people on here have had the same series of flashing lights w/ the common fix being bad wheel sensors I believe. Do some searching, it should come up.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #3 ·
I rescanned it again just now and that same code (P0463) was the only code that came up...

Now, all the lights are out without me even clearing the code. I didn't clear it because I want the dealer to see the code when I bring it in even if the lights do remain out.

Thanks for the reply.
 

·
Registered
Joined
·
6 Posts
my lights came on as we were sitting idling. I had restarted and driven 5 times with the lights remaining on.the owners manual stated that sometimes a metal object under the drivers seat can interfere with the tire pressure and abs sensors. I removed and reinstalled the gas cap, moved a power inverter from under my seat and when I started the car the lights were out.
 

·
Registered
Joined
·
6 Posts
Discussion Starter · #5 ·
The lights came back a few times since I first posted this but they always cleared themselves. I did notice a pattern though - almost every time we filled up, they came on - but when the tank dropped past 3/4 full, they went off.

I took it to the dealer, and after my 2nd visit (this past Monday), they finally changed out the Fuel Level Sensors which hopefully solved the problem. (I haven't filled it yet)

That's an interesting fact about the metal objects under the driver's seat...Thanks for posting that.
 
1 - 5 of 5 Posts
Top