Subaru B9 Trifecta SUV Forum banner
1 - 9 of 9 Posts

·
Registered
Joined
·
22 Posts
Discussion Starter · #1 ·
I own a 2009 Tribeca Premium and it's supposed to have 8 speakers and a sub woofer but there is little to no bass coming from the speakers. I want to verify that the sub is installed and is actually working. Where would I look to verify it?

Thanks.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #3 ·
Hahaha. Ok thanks.

It's really weird. I owned a 2008 Outback XT and it didn't have a sub but the audio was pretty awesome. The Tribeca is supposed to have 8 speakers and a sub and the sound is pathetic.
 

·
Registered
Joined
·
552 Posts
Did they switch the sub on the 08+? 06-07 it's on the passenger side in the trunk...there are 2 plastic grills in the indented area.
 

·
Registered
Joined
·
1,246 Posts
We have the 7 Pass LTD w/ the OE sub and it really sucks. It's way in the back and you can barely hear it when I press my ear to it.

I have the under driver seat OE sub in my 08 Impreza and it is significantly better. I'm guess location is the main factor though.
 

·
Registered
Joined
·
26 Posts
Well, which side is the subwoofer on, when it's at home? On my '07 5 pass, (basic Canadian car comes with sunroof, heated seats etc., but no subw or nav.) there is a grille on the LEFT (driver's) side near the hatch opening from which no sound comes. Presumably it's empty underneath. On the passengers' side there is just that storage pocket. Can an aftermarket sub be mounted behind that grille, anyway?
And don't forget, avjunky, that the bass anyway can be adjusted. Perhaps it's an adjustment problem? Not that the sound is great, but even in my 6 spkr car there's plenty of bass vibrating away against my left leg.
 

·
Registered
Joined
·
22 Posts
Discussion Starter · #9 ·
Ya, I cranked up the bass and there was hardly anything coming from the speakers. I was disappointed considering that my 08 Outback XT had no sub but the bass was much better.
 
1 - 9 of 9 Posts
Top