Subaru B9 Trifecta SUV Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
136 Posts
Discussion Starter #1
I noticed that my audio push on/off button in the middle of the audio buttons doesn't light up at night, is that normal. Also I remember seeing in photos, the displays on both sides of the nav screen, are they suppose to have a blue border light that goes around the outside of each screen. My 07 Tribeca doesn't have this, those two screens don't really do much do they.
And on a side note, I feel the cruise control stalk needed to be lit up at night so you can see what your doing.
 

·
Registered
Joined
·
70 Posts
Well, I as well thought there might be something wrong with my vol/power button since it didn't light up. However, this is the way it is. There is the red light around the button but you would think they could have gotten the letters in the center to light up. As for the other lights around the center clusters....I'd have to check.
 

·
Registered
Joined
·
196 Posts
What about the driver's side lock button? The lock symbol is lit, but not the unlock symbol. The one thing I like is the blue glow in the cup holders (took me a week to notice it).
 

·
Registered
Joined
·
27 Posts
hawker800mech said:
What about the driver's side lock button? The lock symbol is lit, but not the unlock symbol. The one thing I like is the blue glow in the cup holders (took me a week to notice it).
Just the lock button. I do enjoy the backlit cup holders. The red splash lighting from the overhead console is pretty cool too.
 
1 - 8 of 8 Posts
Top