Subaru B9 Trifecta SUV Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter · #1 ·
I am getting a lot of road feel in the accelerator pedal as I drive. You can feel the bumps in the pedal. Any ideas as to why? Goodyear Fortera tires with about 40k miles on them-front end alignment recently done but still the same. 2006 B9 with 105k miles.
 

·
Registered
Joined
·
40 Posts
I'm experiencing the same thing. I'll see if it's weather related and wait for warmer spring temperature. I also hear "clunking" noise, mainly in the front passenger side.
 

·
Registered
Joined
·
7 Posts
Discussion Starter · #4 ·
Road bumps

jaycee said:
I'm experiencing the same thing. I'll see if it's weather related and wait for warmer spring temperature. I also hear "clunking" noise, mainly in the front passenger side.
That is EXACTLY the same place that I feel the noise/bumps are coming from.
 

·
Registered
Joined
·
3 Posts
Me too ... sounds a lot like the infamous front-end sway-bar-bushing/control-arm/strut problem ... whichever one it is.

Yes, I have the same issue, I have about 41K on my '07 right now. Going to bring it in this week if I can find a dealership that will give me a loaner.
 

·
Registered
Joined
·
10 Posts
I would almost guarantee that you either have bad sway bar bushings and/or lower control arm bushings. We had the exact same problem with our '07 Tribeca. First, the dealer attempted to change out the lower control arm bushings, but that didn't help much. Then they went ahead and replaced both lower control arm units. That helped more, but it didn't completely go away. Then they replaced the sway bar bushing and everything was perfect. Thankfully we have the Subaru gold plan extended warranty with no deductible, so everything was free. If you are paying for it out of pocket I recommend replacing the sway bar bushings first, as replacing the lower control arm units is expensive.

Hope this helps.
 
1 - 6 of 6 Posts
Top