Subaru B9 Trifecta SUV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
2009 Tribeca... So, yesterday, about an hour down the highway after refueling, cruise control cut out and the cruise dash light started flashing, the traction control "off" light came on, as did the check engine light.

Another hour or so down the road, and after some anxiety about being able to re-start if I turned off the engine, I let it turn off in the parking lot of a big box car repair place (just in case). Fortunately, it restarted as if nothing was wrong, but the warning lights continued to show.

And a few minutes later when I went to fuel up I discovered the problem...where the gas cap used to be. I'm guessing it was two and a half hours behind me somewhere on the highway. So that's what caused the emissions fault and turned on the Christmas tree on the dash. Once I'd gassed up I put some duct tape over the gas hole to provide some sort of seal. The Christmas lights stayed on.

Today I picked up a replacement gas cap, stripped off the duct tape and drove away. The Tribeca drives fine, but the check engine light and no traction control lights are solid on, and the cruise light continues to flash. I've only driven for some short errands today.

Will the various sensors re-set themselves just by continued driving with a proper gas cap on or do I need to have something re-set?

As always, thank you for your input.
 

·
Registered
Joined
·
1,654 Posts
ANother option - Disconnect your battery.

Or you can buy a $20 scan tool on amazon that can read the codes and reset them.

Tom
 

·
Registered
Joined
·
5 Posts
Discussion Starter #5
Thanks all. Tom, I'd thought about forcing a reset by disconnecting the battery, but the prospect of redoing the radio presets convinced me to give it a couple of days. The Christmas tree went out yesterday when I was running between meetings.

Cheers
 
1 - 5 of 5 Posts
Top