Subaru B9 Trifecta SUV Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
This has now happened to me twice, both times on a 1-1/2 hour drive. The car, which is an 08, appears to be running fine and then I feel a jarring sputter that feels like the car has run out of gas. It recovers and sputters for a bit until I find myself coasting to the emergency lane. The car will then only crank for a second a few times and then stall out, at which point the engine will only turn over with the key. Both times I was towed, the first of which was to a mechanic who kept the car a week and couldn’t get it to fail to start or stall again the entire time. This time I had the vehicle towed to my house, where it started up again on the first try after sitting for 3 hours.

Both incidents occurred with about 2 bars of fuel on the gas gauge.

I have had bad 02 sensor codes for a while, and have suspected my cat is bad, but I’m not sure if that would cause what I have experienced, or if perhaps my fuel filter is clogged. Vehicle has 217,000 on the odometer.

Thoughts on how to proceed?
 

·
Registered
Joined
·
174 Posts
Could be your fuel pump is overheating due to the lower fuel level which also acts as a coolant for the pump. Once it cools down from sitting it goes back to operating. You would need to check the fuel pressure after it stalls and won't start.
 

·
Registered
Joined
·
1,771 Posts
I believe this is a common issue caused by a seal on the gas tank under the middle row seats. Check over at subaruoutback.org for H6 stall threads.
 
1 - 3 of 3 Posts
Top