Subaru B9 Trifecta SUV Forum banner
1 - 20 of 25 Posts

·
Registered
Joined
·
146 Posts
Discussion Starter · #1 · (Edited)
I recently had to change my headlight bulbs and had to disconnect the battery. Now, the only time my temp control controls display the temp (to adjust it) is in the auto mode of the climate control. Otherwise, the dials are black.
I'm certain :cool: this is some kind of setting adjustment, but not so certain :confused: I didn't want to post it here.

Anyone else with this problem?

Solutions?

Thanks,
Doug
 

·
Registered
Joined
·
1,246 Posts
Wait, why did you disconnect the negative to change bulbs?

As for your actual issue, and unlikely, did you check your fuses?
 

·
Registered
Joined
·
146 Posts
Discussion Starter · #3 ·
Had to remove battery to access the headlights. Also needed to clean up the battery and crossbar (tie-down).
BTW, when I went out to the car to drive home from work, the temp controls were lit. I am about to leave for work this morning (in the dark), so will see if they come on.
 

·
Registered
Joined
·
1,246 Posts
Oh, I just take off the battery tie down and shift the battery over to change bulbs.
 

·
Registered
Joined
·
146 Posts
Discussion Starter · #5 · (Edited)
The tie-down was pretty corroded and wanted to catch it before things got bad.
Guess it's time to confess that I have a really bad neck problem that effects my hands and arms so I actually took it to my mechanic to do all this stuff...but took the instructions from the forum with me to help them with it. They said the (illustrated) instructions were great and really helped. They took the tie-down off, sanded it, repainted it, and then coated it with "anti-corrosive stuff."
Update:
On the way to work everything is back to normal...guess the T-bec just had to think it over and sort it out in it's little computer brain. I'm impressed.

Doug

2006 Tribeca Limited 7-passenger
Seacrest Green Metallic
 

·
Registered
Joined
·
48 Posts
Doug, i have experience a similar issue. Most of the time is happens on a cold start up where the HVAC controls do not light up but everything seems to work. It also happened when I disconnected the battery to clean the terminals. Most of the time restarting the vehicle corrected the problem. Also, a few weeks ago the subaru dealer performed a software update to the vehicle with some new calibrations and really haven't had the problem since. However, I'm not sure if that was a fix or not.
 

·
Registered
Joined
·
146 Posts
Discussion Starter · #7 ·
I suspect it IS a fix. This car seems much more computer controlled than any other I've owned. I think I'll go see if they can update my software.

Thanks for your input...a computer term:D

Doug
 

·
Registered
Joined
·
191 Posts
do it yourself climate control unit- out of warranty

my controls for heating and cooling went haywire as if there is a short. seat heaters out..some of the time. most of the buttons are non functional..but I can tape down the temp adjuster and get the a/c to work.

i am out of warantee at 72,000 plus I didnt buy the extended package at 1200-1500.

sounds like the dealer will order a new control unit or send it back to panansonic to be rebuilt... 300 plus labor??is a sort of a quote to be rebuilt.

I found a NEW unit in ebay for 152 shipped...it looks easy to install...dealer get 99 an hour..wish me luck. i will let u know:) should be easier than adding the ipod recepicle that is posted here
 

Attachments

·
Registered
Joined
·
80 Posts
Looks like a good deal! But make sure that the new/replacement control panel has the "LOAD" button on the left side of the CD feeding and unloading slot if you have a 6-CD changer system because if it does not have the "LOAD" button, your CD player is not going to work at all.

tribecadean said:
my controls for heating and cooling went haywire as if there is a short. seat heaters out..some of the time. most of the buttons are non functional..but I can tape down the temp adjuster and get the a/c to work.

i am out of warantee at 72,000 plus I didnt buy the extended package at 1200-1500.

sounds like the dealer will order a new control unit or send it back to panansonic to be rebuilt... 300 plus labor??is a sort of a quote to be rebuilt.

I found a NEW unit in ebay for 152 shipped...it looks easy to install...dealer get 99 an hour..wish me luck. i will let u know:) should be easier than adding the ipod recepicle that is posted here
 

·
Registered
Joined
·
191 Posts
I dont have a 6 disk cd changer. Mine is 1 disk only..Do you think this one will work..as far as I can tell ...
thanks for the reply
dean
 

·
Registered
Joined
·
80 Posts
If what you have is a 1-CD player system, I would say that a panel without a LOAD button should work, assuming the replacement panel is in proper working order..... and, yea, the eBay deal is a steal but to be honest, I'm a little skeptical about it.....don't get me wrong, it's just the confidence and peace of mind that it's going to work or the panel is in perfect/working condition, unless you can make a deal with the seller for a money back guarantee or warranty, then don't let that deal slip away.....Good luck and keep us posted....

tribecadean said:
I dont have a 6 disk cd changer. Mine is 1 disk only..Do you think this one will work..as far as I can tell ...
thanks for the reply
dean
 

·
Registered
Joined
·
191 Posts
sbtango you are right....

sb9tango said:
Looks like a good deal! But make sure that the new/replacement control panel has the "LOAD" button on the left side of the CD feeding and unloading slot if you have a 6-CD changer system because if it does not have the "LOAD" button, your CD player is not going to work at all.
you are right..i think I bought in haste...mine is a 6 cd changer( its my wifes car and I dont GET to drive it that much)

By the way..Do you think she would notice that the cd player doesnt work.:eek:


I am doubled screwed..ordered the wrong part to fix the wifes car the wron:( g way..
 

Attachments

·
Registered
Joined
·
80 Posts
Uh...oh! I don't know man..... either way, when she found out that the CD changer/player is not working, she's going to tell you to fix it you anyway....

To divert her attention, I'm not sure if it's gonna work but it looks like....it's either 1) you need to get her a new iPod or 2) a Sat Radio subscription if she don't have any of those, if she have one of those, then she have no use of the CD player....;)

But seriously, try to return the wrong part and have it exchanged for the correct part.

...and by the way, before you return the "wrong" control panel and spend another $$$ for a new one, for troubleshooting purposes, try to swap the old panel and plug in the "new/wrong" control panel and see if you will solve your temperature control and display issues. If the wrong/new control panel works and solved your temp control/display issues, then you'll verify that your old control panel is the culprit, and it's now down to spending $$$ for the correct panel.... don't forget to buy the one with a LOAD button for 6 CD changer system....:)

tribecadean said:
you are right..i think I bought in haste...mine is a 6 cd changer( its my wifes car and I dont GET to drive it that much)

By the way..Do you think she would notice that the cd player doesnt work.:eek:


I am doubled screwed..ordered the wrong part to fix the wifes car the wron:( g way..
 

·
Registered
Joined
·
80 Posts
Hey Tribecadean... I just had an epiphany..... about the CD player not working when using your new/wrong panel (without the LOAD button).

I'm not sure..... but the CD player/changer might work using the wrong panel IF, the CD changer is loaded with CDs and as long as you don't eject those CDs, because if you eject the CDs, you are not gonna be able to load the CDs again, since the panel does not have a load button.

Just make sure the the CD changer is loaded (while using the old control panel, the one with a LOAD button) before you install and plug in the wrong control panel (the one without the LOAD button) because if there are NO CDs in the changer and you installed the wrong panel, then I am 100% sure that the CD player is NOT going to work because: 1) there is NO disc to play and 2) since there is no LOAD button, then there is no way to load a disc to make the CD player work and play.

Hope this helps and keep us posted!

sb9tango said:
Uh...oh! I don't know man..... either way, when she found out that the CD changer/player is not working, she's going to tell you to fix it you anyway....

To divert her attention, I'm not sure if it's gonna work but it looks like....it's either 1) you need to get her a new iPod or 2) a Sat Radio subscription if she don't have any of those, if she have one of those, then she have no use of the CD player....;)

But seriously, try to return the wrong part and have it exchanged for the correct part.

...and by the way, before you return the "wrong" control panel and spend another $$$ for a new one, for troubleshooting purposes, try to swap the old panel and plug in the "new/wrong" control panel and see if you will solve your temperature control and display issues. If the wrong/new control panel works and solved your temp control/display issues, then you'll verify that your old control panel is the culprit, and it's now down to spending $$$ for the correct panel.... don't forget to buy the one with a LOAD button for 6 CD changer system....:)
 

·
Registered
Joined
·
191 Posts
climate control panel- its fixed-

I googled a used tribeca climate control panel. Got a used one for $210 shipped( it also included the 6 disk changer which I didnt need). it was from a salvage yard,but guarenteed to work.

I got the old one out in less than 4 min..i could have been totally finished in less than 20 min,but I decided to add in an ipod plug,that the 06 doesnt have.


Control panel is in,it works perfectly. the wrong one will get shipped back for refund...so I got the whole thing fixed for $250.

lesson learned there are 2 control panels..one for 6 cd and one for1 cd on the 06..:)

wife is happy..fixed it while she was out of the house:) :)
 

·
Registered
Joined
·
191 Posts
steps - I used a different wire than karen for the ipod

Technology Electronic device Gadget

Wire Electrical wiring Cable Technology Electronic device

Motor vehicle Vehicle Car Auto part Automotive design

Land vehicle Vehicle Car Center console Subaru tribeca

thanks for all the help.sound is great withthe ipod. The volume as to be on "full volume on the ipod" then adjust the volume on the car .

It sounds great and the functions and track select works fine on the ipod. I added a ground wire ,seen in red which clips on to the back of the radio chassis for the additonal ground as described in the prior post.
 

·
Registered
Joined
·
80 Posts
Excellent! Glad to hear that you fixed the issue and be able to get a refund out of the wrong part and most importantly......the wife is happy :)

tribecadean said:
I googled a used tribeca climate control panel. Got a used one for $210 shipped( it also included the 6 disk changer which I didnt need). it was from a salvage yard,but guarenteed to work.

I got the old one out in less than 4 min..i could have been totally finished in less than 20 min,but I decided to add in an ipod plug,that the 06 doesnt have.


Control panel is in,it works perfectly. the wrong one will get shipped back for refund...so I got the whole thing fixed for $250.

lesson learned there are 2 control panels..one for 6 cd and one for1 cd on the 06..:)

wife is happy..fixed it while she was out of the house:) :)
 
1 - 20 of 25 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top