Subaru B9 Trifecta SUV Forum banner

1 - 20 of 20 Posts

·
Moderator
Joined
·
449 Posts
Discussion Starter #1
Has anyone else had inside trim problems? So far there have been three things that have had problems. On the right side second row outside track trim, the hold downs to it have cracked and so has the center one. The other day my wife said the arm rest (bottom half) seemed like a screw was loose. I looked at it and the screws are fine but the metal hinge itself has cracked off. We are still under warrantee and I take it in Tuesday. I've had Subarus for some time now and sure little things happen here and there but this many in such a new one is a little disconcerting. It's not like we are particularly hard on the vehicle either. Just wondering what others have experienced.
 

·
Registered
Joined
·
5 Posts
Peaty... never seen any come back for interior problems at our dealership. My mom drivers her's everyday and hasn't had a bit of problems. Maybe something isloated to your specific vehicle... sorry to hear that. Still think 06-07 best Tribecca.

-Jason
Avondale Subaru Sales
 

·
Moderator
Joined
·
449 Posts
Discussion Starter #3
We've had ours longer than most people I would bet, got it 12-05 if I remember right. We haven't had any other issues and we are very happy with it. I just found it strange is all. I think the fact that the middle seat goes back so far when you aren't using the third row exposes the trim to excess foot traffic as the kids get in and out.
 

·
Registered
Joined
·
196 Posts
I've had the plastic trim on the rear hatch make noise in cold weather over bumps. Very annoying. I fixed it last year, but I have noticed a little noise on cool mornings recently, again. Next month will be one year for me in my B9. Still happy with it.
 

·
Registered
Joined
·
1,246 Posts
No worries yet for us, but we haven't had it that long. Only a month now and so far so good.
 

·
Moderator
Joined
·
449 Posts
Discussion Starter #6
Well we take in tomorrow to have the parts looked at and ordered. I'll report back.
 

·
Registered
Joined
·
9 Posts
Small issues

Yep, some durability issues with the small stuff here as well. The tether for the gaz cap broke. I wouldn't expect to get more than a few months out of the one that replaced it. Crappy design, that's all. The tire jack broke, while changing the tire. That one was somewhat more disconcerting, as I had to waist time on roadside assistance instead of getting on my way.
 

·
Registered
Joined
·
192 Posts
Peaty said:
Has anyone else had inside trim problems? So far there have been three things that have had problems. On the right side second row outside track trim, the hold downs to it have cracked and so has the center one. The other day my wife said the arm rest (bottom half) seemed like a screw was loose. I looked at it and the screws are fine but the metal hinge itself has cracked off. We are still under warrantee and I take it in Tuesday. I've had Subarus for some time now and sure little things happen here and there but this many in such a new one is a little disconcerting. It's not like we are particularly hard on the vehicle either. Just wondering what others have experienced.
Peaty, is it possible you stole my Tribeca or something because mine has those EXACT problems!!! :lol:

Actually, the hinge on my center console snapped completely and is merely resting in place right now. If I am not careful when I open it, the cover falls off completely. One time, it fell off onto my 8-year old's foot! Luckily, it didn't hurt her to bad or ruin her ice skating career!

Another issue I have had is the rear gate interior where the white LED is, i was using the thrid row and had the minimized cargo area filled to capacity. I guess when I shut the lift gate, the cargo somehow pushed the led panel inside the gate. I was able to get it out and back into place, but this is something else to look out for...
 

·
Moderator
Joined
·
449 Posts
Discussion Starter #9
Yesterday while putting masking tape on the trim parts that needed to be replaced I managed to have the whole hing come apart. The end that was not snapped slid off the pin. So mine is apart too.
 

·
Moderator
Joined
·
449 Posts
Discussion Starter #10 (Edited)
Went and got the keys to the Tribeca just now. They had the car to just look at and get the proper part numbers to order. I didn't expect them to have them in stock. They also looked at the rear gas struts that hold up the hatch. Some of them had issues but mine have always been find. This is the invoice here:



Only the hinge (metal part) is broken but it seems they have ordered the whole thing. You can see the PN's in the invoice, I may check the cost just out of curosity. Everything is covered though. Not that I didn't expect it to be. I've gotten quite a few Scoobies at this dealer and they have always treated me right.

edit: Looks like the hinge is not too bad cost wise:

92117XA00A Hinge Compl $20.35
$15.51
 

Attachments

·
Registered
Joined
·
196 Posts
Magic Marker said:
Thanks. Since we have an 07, doesn't look like it should affect me.
I have an 07, and the dealer had no problem changing mine. My struts are real weak in the cold. I first noticed it when I opened the hatch and leaned in and smacked my head into the hatch.:rolleyes:
 

·
Moderator
Joined
·
449 Posts
Discussion Starter #16
Got a call today and all the parts are in already, that was quick. gotta set aside some time to drop the car off again I guess.
 

·
Moderator
Joined
·
449 Posts
Discussion Starter #17
We took the car in yesterday and got all the parts replaced. Looks like they repalced all the moving parts in the center console, top and middle part. Everything seems back to normal :)
 

·
Registered
Joined
·
1,246 Posts
Magic Marker said:
No worries yet for us, but we haven't had it that long. Only a month now and so far so good.
I spoke too soon. The B9 is now 12K old. It's between 25-30 degrees outside and we're driving on the highway. I'm experiencing some squeaking noises sound like plastic rubbing coming from the area right under the windsheild/ driver side.

Anyone having that noise issue?
 

·
Registered
Joined
·
25 Posts
I heard some squeaking / cracking noises the other day, in the windshield area, before the car got warmed up. It was in the high 20's outside. It was the first time I heard it and it went away, but I really think the issue I'm having with the car not getting warm (even when it's cranked up to 75) is related to a bad windshield install. At least that's what I'm hoping.

So, if it's any consolation, I've heard a similar noise.
 

·
Registered
Joined
·
1,246 Posts
JimHam said:
I heard some squeaking / cracking noises the other day, in the windshield area, before the car got warmed up. It was in the high 20's outside. It was the first time I heard it and it went away, but I really think the issue I'm having with the car not getting warm (even when it's cranked up to 75) is related to a bad windshield install. At least that's what I'm hoping.

So, if it's any consolation, I've heard a similar noise.
Thanks. I'm glad it's just not me. Once it warms up and if it continues, I'll get the dealer involved.

BTW JimHam, don't forget to sign into my NJ/NY regional thread!
http://www.sb9t.com/forums/showthread.php?p=3084#post3084
 
1 - 20 of 20 Posts
Top