Subaru B9 Trifecta SUV Forum banner

1 - 5 of 5 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1 (Edited)
I purchased a 2007 B9 Tribeca about two months ago, with about 150,000 miles. Two weeks after buying it, the alternator died and I replaced it with this:

https://www.amazon.com/Premier-Gear-PG-11225-Professional-Alternator/dp/B00KY07PR2

The car ran perfectly until this Thursday morning, after a rare massive downpour here in Albuquerque, NM. That morning, the "r.diff temp", emergency brake, and battery light were on constantly, and the headlights flickered. The car drove with no issues. When I used it during the afternoon the lights on dash were flickering intermittently rather than on constantly. By that night, the problem had ceased altogether. Tonight, another heavy rain storm, the problem returned.

The only OBD code is P0050 -- HO2S Heater Control Circuit B2S1.

Googling suggests people have had similar issues resulting from a bad connection at the rear diff temperature sensor, or that the new alternator may be the problem. I'll update tomorrow to indicate whether the problem goes away after everything dries out again.

Any thoughts as to what is causing this? I'm taking it in to the dealership next week to fix the recalled airbag and hood latch. Anything I should ask them to examine specifically given this electrical problem?

Thanks!
 

·
Registered
Joined
·
1 Posts
I hope you find the answer and report back. Im having the exact same problem on my T9 but mine dosen't appear to be water related. Very dry here in Utah.I also replaced 2 alternators thinking one might be bad from autozone. No difference after second swap. I did notice the output voltage from alternator was spiking between 11 up to 17 volts. Also, the car will put itself in sport mode. Has yours kicked into sport mode on its own ? I think i need to have an exorcisim performed on this Subu
 

·
Registered
Joined
·
154 Posts
It has been reported here that you have to use the Subaru h6 alternator or bad things can happen. It seems to be the common denominator here.
 

·
Registered
Joined
·
1 Posts
I have a 2006 B9 Tribeca, and this happened to me this morning while driving in the rain. The light flickered but didnt stay on. The flickering went away when I picked up speed. When I got home I shut off my car and waited a bit and turned it back on with no problems. Is this maybe just a rain problem or something more serious?
 
1 - 5 of 5 Posts
Top