Subaru B9 Trifecta SUV Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter #1
Hi - First time posting here. I have an ErSS code on my dash. Driving 2007 B9 Tribeca. I eventually worked my way through some forums and was able to get the chassis codes. I'm pretty sure I have a speed sensor issue, but I'm trying to figure out which wheel it's coming from, and I expected these codes would tell me.

Unfortunately, after scouring the internet and multiple forums, I cannot find any resource that tells me what these 2 particular codes mean:

I have the following:
C0231
C0421

Can anyone interpret these for me?? I took a cursory glance at both of the front speed sensor wires and followed from the wheel hub to the engine bay, and neither of them look damaged externally.
 

·
Registered
Joined
·
1,696 Posts
Have you had your wheel bearings or CV axles replaced recently? Non-OEM wheel bearings are most likely cause of this.

Tom
 

·
Registered
Joined
·
3 Posts
Discussion Starter #5
Here's link where a fellow tribeca owner and member (psygnal11) had the same codes. Seems related to wheel speed sensor, although he also had issues confirming the actual code.

http://www.subaruoutback.org/forums/99-do-yourself-illustrated-guides/19053-06-09-how-read-diagnostic-trouble-codes-dtcs-4.html#post1454786
Great link! Thank you. This is an almost identical issue. The code theory of replacing "0" with "4" on the detailed code column within the VDC Diagnostics trouble code table is exactly correct!

I was able to essentially confirm this today. After Subaru dealership threw a fit when I asked them to give me the button combination to bring up the chassis codes, the GM of the dealership gave me free diagnostics using their Subaru Select Monitor.

My Chassis Code on odometer: C0231
"0" to "4" Conversion = 4231
VDC Diag. Trouble code Table --> Detailed Code = 4231 = FL wheel speed sensor open line
Subaru Dealership Select Monitor Diagnostics = C0023 = Front Left ABS Sensor Circuit Open

Now I have to figure out if I need a new sensor or the wheel hub/tone ring?
 

·
Registered
Joined
·
1,696 Posts
Almost certainly a wiring issue it would seem. tone ring I think is a different code. Something along the lines of speed sensor disagrees with others.

Good luck! Start with some basic wiring diagram reading and see what you can learn. PlainOM over on subaruoutback.org really gets in to the electrical diagnostics and be a big help!
 
1 - 7 of 7 Posts
Top