Subaru B9 Trifecta SUV Forum banner
1 - 6 of 6 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Got an error light on where trip odometer should be. took it to dealership and they replaced sensore to vacuum pump. light still on . now they want car back for a complete computer diagnostic checi.

Other sourses say servie manual doesn not specifically mention error message er bb or er 66. Thinks it is a communication problem with LAN. Says very tricky to repair.

anyone experience same problem and if so how was it fixed? thanks!
 

·
Registered
Joined
·
139 Posts
We had the same thing - communication problem with "body integration unit" and your vacuum system. Isn't a safety concern, but does need to be checked out.

Have your dealer call Evergreen Subaru in Maine, USA and talk to their service manager Joel. He'll tell 'em exactly how to fix yours, because he fixed mine three months ago :)
 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
er bb prob

thanks for the info. i had car back i today and they apparently came to the conclusion that the vacuum pump was indeed the problem and are confident it will be taken care of as soon as they get the part. i hope so, and i will post the results in hopes of helping others. frustrating that this code was so hard to pin down. one would think that if an error code is programmed into the system, that error code should be able to be readily accessed. isn't that the whole point of computer diagnostics in automobile repair?
 

·
Registered
Joined
·
139 Posts
Yeah, I don't know either. A quick Google of the error code when it first appeared gave me enough information to get the service guys pointed in the right direction.
 
1 - 6 of 6 Posts
Top