Subaru B9 Trifecta SUV Forum banner

1 - 4 of 4 Posts

Registered
Joined
16 Posts
Discussion Starter #1
Hello, I have a 2006 Tribeca limited and have been struggling to fix a problem with the brakes. My daughters car so I don鈥檛 mind throwing new parts at the problem, but I am out of new parts. 馃榾
When you pump the brakes (very firm peddle), push brake peddle, and start car, the peddle will gradually go almost all the way to the floor. When I pump the brakes it builds up pressure and then goes to the floor. I have replaced booster, master (twice), vacuum pump, and all vacuum hoses.

I have all the vacuum hoses pointed away from booster I have performed vacuum tests to confirm they hold to 18 in hg. I assume that all the hoses should go away from booster.

I have 16-18 in hg vacuum at manifold.

I tried to use my vacuum pump to measure the in hg at booster, but get nothing. Does this mean the new booster is bad?

Any help is greatly appreciated!
 

Registered
Joined
16 Posts
Discussion Starter #2
Hello, I have a 2006 Tribeca limited and have been struggling to fix a problem with the brakes. My daughters car so I don鈥檛 mind throwing new parts at the problem, but I am out of new parts. 馃榾
When you pump the brakes (very firm peddle), push brake peddle, and start car, the peddle will gradually go almost all the way to the floor. When I pump the brakes it builds up pressure and then goes to the floor. I have replaced booster, master (twice), vacuum pump, and all vacuum hoses.

I have all the vacuum hoses pointed away from booster I have performed vacuum tests to confirm they hold to 18 in hg. I assume that all the hoses should go away from booster.

I have 16-18 in hg vacuum at manifold.

I tried to use my vacuum pump to measure the in hg at booster, but get nothing. Does this mean the new booster is bad?

Any help is greatly appreciated!
I used a hand pump on the booster and couldn鈥檛 get more than 10 in hg. It wouldn鈥檛 hold more than 5 seconds. I read online that I should be able to pump up to 20 and it should hold for a while. Seems to me the new booster is bad. You agree?
 

Registered
Joined
562 Posts
I generally agree. Just a weird scenario.
 

Registered
Joined
16 Posts
Discussion Starter #4
I generally agree. Just a weird scenario.
I have been chasing this for a while. I don鈥檛 think the vacuum pump kicks on. I verified sensor, pump, relay are working. If I crimp the vacuum line to sensor, shouldn鈥檛 the pump kick on?
 
1 - 4 of 4 Posts
Top