Subaru B9 Trifecta SUV Forum banner
1 - 14 of 14 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
I have only had our B9 since November, so I'm not too sure if what I'm hearing is normal; whenever I go over any kind of (substantial)bumps, I can "hear" a soft, semi "clunk" (great description, eh??:rolleyes:) from the front end area (any speed). I have driven a couple of SUV's over the years, and THINK I remember hearing/feeling a similar thing, so I'm not sure if I'm making something out of nothing...

Anyone else hear or feel the same kind of thing, or is this something I should have the dealer look at? Thanks guys! Cheers
 

·
Registered
Joined
·
196 Posts
I now that when I go a little too fast over speed bumps and road dips that it sounds like the front struts top out. Also, there has been an issue with the front swaybar links that have prematurely worn out that can cause a little noise.
 

·
Registered
Joined
·
82 Posts
I've got the same noise on our new/used 06 with 33K. I've got a small list of warranty items to be loked at before 36K and that's one of them. As a service manager for an independant repair facility, I've heard a lot of noises like this, it does indeed sound like upper strut mounts or sway bar links. I'm going do inspect it at our shop at the next oil service, then bring it in for warranty. I'll let you know what I find on our Tribeca.
 

·
Registered
Joined
·
82 Posts
Well after doing the 30K and inspecting the entire front end, nothing could be found loose. But we did find a service bulletin for a possible broken/cracked engine strut mount on the firewall. It only applies to the '06MY which mine is. It requires drilling spot welds out and rewelding? Only pays 1 hour warranty time. I need to bring the beca in to Subaru for a couple other issues under warranty so I'll mention this as well.
 

·
Registered
Joined
·
33 Posts
jonnyk said:
I have only had our B9 since November, so I'm not too sure if what I'm hearing is normal; whenever I go over any kind of (substantial)bumps, I can "hear" a soft, semi "clunk" (great description, eh??:rolleyes:) from the front end area (any speed). I have driven a couple of SUV's over the years, and THINK I remember hearing/feeling a similar thing, so I'm not sure if I'm making something out of nothing...

Anyone else hear or feel the same kind of thing, or is this something I should have the dealer look at? Thanks guys! Cheers
It is the front bushings, I had my replaced two days ago. Now when
I go over any bumbs it stop making that sound.
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #10 ·
took mine in yesterday and had the front bushings replaced, under warranty. It was really good to use the warranty, as its an American car imported into Canada, but my local dealer gave me 0 hassles, and everything went well.

A little miffed that they told me that the wiper blades were not under warranty, even though I'm pretty sure the little warranty book says they are... thats alright, I want the blades replaced with ones that don't suck! :)
 

·
Registered
Joined
·
196 Posts
jonnyk said:
took mine in yesterday and had the front bushings replaced, under warranty. It was really good to use the warranty, as its an American car imported into Canada, but my local dealer gave me 0 hassles, and everything went well.

A little miffed that they told me that the wiper blades were not under warranty, even though I'm pretty sure the little warranty book says they are... thats alright, I want the blades replaced with ones that don't suck! :)
Which bushings? The lower control arm or swaybar?
 

·
Registered
Joined
·
26 Posts
jonnyk said:
took mine in yesterday and had the front bushings replaced, under warranty. It was really good to use the warranty, as its an American car imported into Canada, but my local dealer gave me 0 hassles, and everything went well.

A little miffed that they told me that the wiper blades were not under warranty, even though I'm pretty sure the little warranty book says they are... thats alright, I want the blades replaced with ones that don't suck! :)
They should be under warranty! Subaru used to charge me for them, but the lady at the desk then told me that they are covered, and that she would refund me... Thought that was awesome! Especially when she only worked at the desk ha! Hope the same works out! And I cannot wait to get my bushings replaced, its just getting worse and worse! Happy clunking ha!
 

·
Registered
Joined
·
32 Posts
SAME ISSUE HERE - Swaybar bushings

FYI - I had the same issue with my front sway bar bushings - both sides. Mileage-29,500. It's covered under warranty - but it makes me wonder if they went bad this early, is it going to be an on-going problem???

I sure hope not.:confused:
 
1 - 14 of 14 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top