Subaru B9 Trifecta SUV Forum banner
1 - 13 of 13 Posts

·
Registered
Joined
·
54 Posts
Discussion Starter · #1 ·
08 tribeca ~8k.
Sometimes smell a little coolant when getting out of the tribeca after a drive.
So far I haven't spotted any leaks or noticed alot of coolant loss.
Had the same thing on the forester. Seemed to be better after the first coolant drain and fill and putting in the subaru coolant conditioner....

Anyone else noticed this?
Wondering if I should just go ahead with a coolant change or take it in to the dealer.
 

·
Registered
Joined
·
552 Posts
I haven't noticed any coolant smells in our 07. I'd really just watch the level, before doing anything.
 

·
Registered
Joined
·
19 Posts
immortal_suby said:
08 tribeca ~8k.
Sometimes smell a little coolant when getting out of the tribeca after a drive.
So far I haven't spotted any leaks or noticed alot of coolant loss.
Had the same thing on the forester. Seemed to be better after the first coolant drain and fill and putting in the subaru coolant conditioner....

Anyone else noticed this?
Wondering if I should just go ahead with a coolant change or take it in to the dealer.
Yes. Same thing on our 2007. Dealer is stumped. As am I. No drop in level, none of the tell tell signs of anti freeze smells...puddles, white, sweet smoke out of exhaust. Dealer says not enough of a smell for them to notices, and pressure tested with no leaks...nothing on the garage floor. But it smells like hot AF.

Look under your hood, and see where the coolant fill cap is? Underneath the radiator hose is the overflow hose to the resevoir...I'll BET YOU that you have a buildup on that hose...some how, its leaking and getting on that hose...my guess would be from start up pressure.
 

·
Registered
Joined
·
192 Posts
My '06 Tribeca has this same problem. I have never been able to figure it out.

On a related note, I have occasionally times where when idling for awhile with the AC on (eg: my wife needs to run into the store) the temperature starts climbing near the top, the cooling fan kicks into high, but there are no other signs of real overheating. It never happens for the dealer, and when they pressure check the system, it is fine. They even flushed the whole system just to be sure is not an air bubble or anything.

Something is screwy with the Tribeca's cooling system... :(
 

·
Registered
Joined
·
124 Posts
Sometimes I smell something like anti-freeze just for about a minute when starting the car up when its cold. This most often occurs when its cold (~-20 or more) and I drive for a couple minutes, park for a bit and start the car again. Its like the first blast of air in the vents smells like coolant.
 

·
Registered
Joined
·
1 Posts
Antifreeze Smell at Start Up Tribeca

I have a 2006 Tribeca with 41k miles. For the past year I get a strong antifreeze smell, which is most noticeable on start up. It's at the dealer now for the second time and of course they can't find anything and don't even want to do a pressure test. When I first started noticing the smell a year ago the reservoir was empty. I filled it with distilled water and marked the level. It is down about 2 inches from that level. I haven't found any leaks and I have smelt the exhaust on start up and it doesn't seem to be coming from the exhaust. Not sure if it just evaporation through the cap or something else. I have also now noticed my 2005 Legacy GT Wagon with 40k miles has an antifreeze smell on start up and some other times. Again no leaks. Is this a normal Subaru occurrence? I can't figure it out. Antifreeze smell on a cars start up always meant to me antifreeze was somehow seeping into the engine through gaskets or valve guides. Not a good scenario, so I want to figure it out before the powertrain warranty is up. Any help?
 

·
Registered
Joined
·
180 Posts
Same smell on our '07. No one has been able to find the cause, but levels stay normal.
Get the same smell on my '02 Foz. I think the AF is still burning off from the leaky hose I fixed on the side of the MassPike.
 

·
Registered
Joined
·
192 Posts
I used to often get this smell as well but ever since the dealer took another stab at fixing my overheat while idling problem, it seems to have gone away (so did the overheating for now). What they replaced this time was the throttle body gasket.

I hope this helps!!!
 

·
Registered
Joined
·
52 Posts
immortal_suby said:
08 tribeca ~8k.
Sometimes smell a little coolant when getting out of the tribeca after a drive.
So far I haven't spotted any leaks or noticed alot of coolant loss.
Had the same thing on the forester. Seemed to be better after the first coolant drain and fill and putting in the subaru coolant conditioner....

Anyone else noticed this?
Wondering if I should just go ahead with a coolant change or take it in to the dealer.
Hey, it looks like we are both on both of these forums! Did you ever track down the source of your coolant smell?
 

·
Registered
Joined
·
42 Posts
I had the same thing on the 08. It was a bad radiator cap. Works fine now. I noticed the smell on steep inclines in the mountains while towing a camper.
 
1 - 13 of 13 Posts
Top