Subaru B9 Trifecta SUV Forum banner

1 - 6 of 6 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
My tribeca has 68000 miles on it and I'm having transmission problems. My repair man said he can't fix it need to go to Subaru dealer. Thinks its a dealr valve abody part? Does that sound familiar to anyone? Thinks its a 1000.00 + part? Help anyone?
 

·
Registered
Joined
·
1,760 Posts
If that is the only one, it could just be the valve body that needs to be replaced, but it could also been that the clutch pack is failing.

Might be as simple as wires, bad battery or bad alternator. As bad as transmission burnt up and you need a new one. Subaru dealer is your best bet, unless you want to tackle it on your own to diagnose. Check this thread on what you would need to do: http://www.subaruoutback.org/forums...experienced-failed-turbine-2-signal-5eat.html
 

·
Registered
Joined
·
703 Posts
What exactly are the transmission problems that you're having? Is there a problem with the operation (e.g. hard shifts, slipping, etc.)? Is the car making funny noises (clunking, grinding, clicking, etc.)? Is it just a CEL that brought your attention to this?
 
  • Like
Reactions: Uncle vern

·
Registered
Joined
·
5 Posts
Noobie here, and thanks for the add.
I have a 2008 Tribeca 3.6L 5EAT AWD. It starts like this, my daughter was driving my wife's Tribeca a few months backs, she calls me and said that a bunch of lights on the dash came on while driving. AT oil temp, traction control, check engine, and flashing cruise light, she stopped the car, she didn't have anything go wrong just the lights. She googles this before I could do anything, found that it might be the transmission, what should I do?, I told her to shut the car off and wait about 15 minutes and then see if it will go. She did, it ran and the lights went off. When she came home I looked at the car, the lights were not on and I couldn't get it to do it for me. About a week later I was driving the car taking my grandson home, without warning, no hard shift, nothing, just driving on a straight road about 50 MPH, the lights decided to show up. I pulled over, and just sat there with it running, placed it in reverse, no problem, placed it in drive, no problem, lights still on I continued on driving, got my grandson home and visit with my daughter, we talked about the lights on the car. I got in, started it up and the lights were out. I hate to write a book here but, more input the better....right?
Anyways, got home and thought well check the fluid, we have had it for about a year, its got 100k+ miles on it, the fluid was dark but not burnt and just enough red tint to tell that it's tranny fluid.

So I go about the norm, look for fluid, check forums the usual google stuff and the youtube machine, so I continue to drive the car no problems, then on day about a week later visiting some family, I slowed down to turn onto their street and BANG!, it was like I got rear ended, a few seconds later the dash lights up, same as above but it didn't drive any different. Time to go home, we got in the car and headed home it's only a 15 min drive, the lights stayed on and the next day I got my friends scanner and checked for codes, P1017? the common one that everyone seems to be getting. So I do the search here and a few other forums and of course, youtube, boiled down to replacing the valve body.
Yes I bought one new from a dealer, got it for around 7bills, it came in, I installed it last week and went to test drive it and it will not shift out of 1st and I got lights, AT oil temp flashing, flashing cruise, ABS, check engine, and last but not least the traction control light.
Now with all that said... what did I do wrong? I do remember seeing something about the shift position and making sure it's in the right position on the valve body, not sure if it was or not and when I installed it, I did look to at the old one to see where it was placed and I positioned the new one in the same spot....I think....not sure though, but could this be giving me the problem?
thanks in advance.
 
1 - 6 of 6 Posts
Top